Electronics & Programming

develissimo

Open Source electronics development and programming

  • You are not logged in.
  • Root
  • » Java
  • » One simple question about Eclipse [RSS Feed]

#1 Nov. 6, 2005 11:34:30

Nikita S.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

One simple question about Eclipse


Hi.

Just one question: why package eclipse-base depends on gij-4.0 and not
java-runtime ?

Nikem.


--
To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact

Offline

#2 Nov. 6, 2005 19:53:53

Joe S.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

One simple question about Eclipse


"Nikita Salnikov-Tarnovski" <> wrote in messageHi.

Just one question: why package eclipse-base depends on gij-4.0 and not
java-runtime ?

Nikem.I would like to know that. I thought I was assured that java-runtime wouldbe used so that I did not need to download a free JVM. I use the sun JVMbecause I need to work with programs that use (abuse?) the latest javafeatures. I see no reason to have both Sun's and a free JVM.Also: should eclipse-platform provide ant? Since it appears to be includedin the form of a plugin it would be nice to have eclipse-platform includeany files needed so that the included ant can be used as the main ant of thesystem. As it is currently, installing eclipse-sdk will pull in'ant-optional' which requires 'ant' (a versioned dependecy unfortunately).Eclipse-sdk also pulls in 'libtomcat-java' which requires 'ant'.--
To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact

Offline

#3 Nov. 7, 2005 07:05:26

Michael K.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

One simple question about Eclipse


On Sun, Nov 06, 2005 at 01:22:25PM +0200, Nikita Salnikov-Tarnovski wrote:
> Hi.
>
> Just one question: why package eclipse-base depends on gij-4.0 and not
> java-runtime ?

This is a part-time solution. We need a script which generates the
master db file for the native jars of eclipse. This script is included
in eclipse-base. a better script for this will be included in gcc-4.0 or
java-gcj-compat soon. Then we can just call it from our postinst/postrm
scripts in eclipse. Until this is done we need it in eclipse. The script
needs a tool called gcj-dbtool. This tool is included in gij package.
That is why eclipse-base depends on it for now. This will be removed
soon.


Cheers,
Michael
--
Escape the Java Trap with GNU Classpath!http://www.gnu.org/philosophy/java-trap.htmlJoin the community athttp://planet.classpath.org/--
To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact

Offline

  • Root
  • » Java
  • » One simple question about Eclipse [RSS Feed]

Board footer

Moderator control

Enjoy the 20th of November
PoweredBy

The Forums are managed by develissimo stuff members, if you find any issues or misplaced content please help us to fix it. Thank you! Tell us via Contact Options
Leave a Message
Welcome to Develissimo Live Support