Electronics & Programming

develissimo

Open Source electronics development and programming

  • You are not logged in.
  • Root
  • » Java
  • » Multiple versions of libasm*-java [RSS Feed]

#1 May 25, 2010 12:25:46

Onkar S.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Multiple versions of libasm*-java


Hi all,

We currently have three versions of libasm*-java in repositories each
one corresponding to specific major version form upstream. The
packages are libasm-java, libasm2-java, libasm3-java. A quick look at
upstream download page tells that only version 3.x is being
maintained.
Unless there are backward compatibility problem with 3.x version
should we start working on the migration of (build)-rdeps of old
versions?

(build)-rdeps of libasm-java in main
libjmock-java/jmock
libaspectwerkz2-java/aspectwerkz2

(build)-rdeps of libasm2-java in main
Reverse Depends:
libxbean-java
libspring-core-2.5-java/libspring-2.5-java
libjasperreports-java/jasperreports
jardiff
libcommons-jci-java/commons-jci
substance
ow-util-ant-tasks
liblaf-widget-java


Onkar
--
Passion - Some people climb mountains - others write Free software.
Don't ask why - the reason is the same.


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/aanlktiktf5d87bfwgtytughq_agvsyovbvaa0vidw...@mail.gmail.com

Offline

#2 May 28, 2010 23:11:18

Torsten W.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Multiple versions of libasm*-java


Hi Onkar,

On Tue, May 25, 2010 at 1:25 PM, Onkar Shinde <onkarshi***@*mail.com> wrote:
> Unless there are backward compatibility problem with 3.x version
> should we start working on the migration of (build)-rdeps of old
> versions?

yes we should. Thanks for the list. That might be a job for the Debian
Miniconf in june...

Cheers,
Torsten


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/aanlktikz88bxmdti70staanr08vhnmim9goqkdc6h...@mail.gmail.com

Offline

#3 June 4, 2010 23:54:14

Damien R.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Multiple versions of libasm*-java


Le mardi 25 mai 2010 13:25:11, Onkar Shinde a écrit :
> Hi all,

Hi Onkar,

> We currently have three versions of libasm*-java in repositories each
> one corresponding to specific major version form upstream. The
> packages are libasm-java, libasm2-java, libasm3-java. A quick look at
> upstream download page tells that only version 3.x is being
> maintained.
> Unless there are backward compatibility problem with 3.x version
> should we start working on the migration of (build)-rdeps of old
> versions?
> (build)-rdeps of libasm2-java in main
> Reverse Depends:

> libspring-core-2.5-java/libspring-2.5-java


From my last build test neither libspring-2.5-java nor libspring-java (3.0)
can be built with libasm3-java (fail to build with errors regarding
ClassVisitor interface, IIRC).

Don't take it as a -1 against your proposal, but it's a "call for patch" on
those libspring-* packages before RM old ASM packages :)

Cheers,
--
Damiensignature.ascDescription:This is a digitally signed message part.

Attachments:
attachment signature.asc (198 bytes)

Offline

#4 June 5, 2010 01:15:11

Miguel L.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Multiple versions of libasm*-java


On Fri, Jun 4, 2010 at 6:16 PM, Damien Raude-Morvan <draz***@*razzib.com> wrote:
> From my last build test neither libspring-2.5-java nor libspring-java (3.0)
> can be built with libasm3-java (fail to build with errors regarding
> ClassVisitor interface, IIRC).
>
> Don't take it as a -1 against your proposal, but it's a "call for patch" on
> those libspring-* packages before RM old ASM packages :)

The same happens with libeclipselink-java. It Build-Depends on
libasm-java and libasm2-java. If you try to build it with only libasm2-java
or with libasm3-java it fails with similar errors (asm.CodeVisitor and
asm.Constants are not found among other errors).

--
Miguel Landaeta, nomadium at gmail.com
secure email with PGP 0x7D8967E9 available athttp://keyserver.pgp.com/"Faith means not wanting to know what is true." -- Nietzsche


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/aanlktinpohfq9kcnahplk8qmhpkqmqlxkbuj8oqwy...@mail.gmail.com

Offline

#5 June 15, 2010 09:15:28

Onkar S.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Multiple versions of libasm*-java


On Sat, Jun 5, 2010 at 4:16 AM, Damien Raude-Morvan <draz***@*razzib.com> wrote:
<snip>
> From my last build test neither libspring-2.5-java nor libspring-java (3.0)
> can be built with libasm3-java (fail to build with errors regarding
> ClassVisitor interface, IIRC).
>
> Don't take it as a -1 against your proposal, but it's a "call for patch" on
> those libspring-* packages before RM old ASM packages :)
</snip>

The problem was with changed API of ClassReader. After going through
the API differences bet 2.x and 3.x version as mentioned at I was
able to produce the patch. The changes have been committed to pkg-java
svn. Can you please upload the package?
Please note that I have also added a new package
libspring-aspects-2.5-java. So it will go through binary NEW queue.


Onkar


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/aanlktilwjtblyun57o9tlt6q2uk0tstfu-j_zkm9v...@mail.gmail.com

Offline

#6 June 15, 2010 09:16:06

Onkar S.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Multiple versions of libasm*-java


On Tue, Jun 15, 2010 at 1:44 PM, Onkar Shinde <onkarshi***@*mail.com> wrote:
> On Sat, Jun 5, 2010 at 4:16 AM, Damien Raude-Morvan <draz***@*razzib.com>
> wrote:
> <snip>
>> From my last build test neither libspring-2.5-java nor libspring-java (3.0)
>> can be built with libasm3-java (fail to build with errors regarding
>> ClassVisitor interface, IIRC).
>>
>> Don't take it as a -1 against your proposal, but it's a "call for patch" on
>> those libspring-* packages before RM old ASM packages :)
> </snip>
>
> The problem was with changed API of ClassReader. After going through
> the API differences bet 2.x and 3.x version as mentioned at I was
> able to produce the patch. The changes have been committed to pkg-java
> svn. Can you please upload the package?
> Please note that I have also added a new package
> libspring-aspects-2.5-java. So it will go through binary NEW queue.

Oops. The link to API differences details ishttp://asm.ow2.org/jdiff223to30/changes.htmlOnkar


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/aanlktimdtmg6xadde4kh8ok43v0cfslhf0cjfprxu...@mail.gmail.com

Offline

#7 June 16, 2010 20:27:10

Damien R.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Multiple versions of libasm*-java


Le mardi 15 juin 2010 10:15:43, Onkar Shinde a écrit :
> On Tue, Jun 15, 2010 at 1:44 PM, Onkar Shinde <onkarshi***@*mail.com> wrote:
> > On Sat, Jun 5, 2010 at 4:16 AM, Damien Raude-Morvan <draz***@*razzib.com>
> > wrote: <snip>
> >
> >> From my last build test neither libspring-2.5-java nor libspring-java
> >> (3.0) can be built with libasm3-java (fail to build with errors
> >> regarding ClassVisitor interface, IIRC).
> >>
> >> Don't take it as a -1 against your proposal, but it's a "call for patch"
> >> on those libspring-* packages before RM old ASM packages :)
> >
> > </snip>
> >
> > The problem was with changed API of ClassReader. After going through
> > the API differences bet 2.x and 3.x version as mentioned at I was
> > able to produce the patch. The changes have been committed to pkg-java
> > svn. Can you please upload the package?
> > Please note that I have also added a new package
> > libspring-aspects-2.5-java. So it will go through binary NEW queue.

Thanks for your patch!
Uploaded to unstable.

> Oops. The link to API differences details is
>http://asm.ow2.org/jdiff223to30/changes.htmlI'll look at your link to make patch for my Spring 3.x package (still WiP...)

Cheers,
--
Damien - Debian Developperhttp://wiki.debian.org/DamienRaudeMorvansignature.ascDescription:This is a digitally signed message part.

Attachments:
attachment signature.asc (198 bytes)

Offline

  • Root
  • » Java
  • » Multiple versions of libasm*-java [RSS Feed]

Board footer

Moderator control

Enjoy the 15th of December
PoweredBy

The Forums are managed by develissimo stuff members, if you find any issues or misplaced content please help us to fix it. Thank you! Tell us via Contact Options
Leave a Message
Welcome to Develissimo Live Support