Electronics & Programming

develissimo

Open Source electronics development and programming

  • You are not logged in.

#1 June 21, 2010 19:10:44

Niels T.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

RFS: icu4j-4.2


HiI have prepared a new upstream release of icu4j; since eclipse 3.5 needs4.0.1.1, I have renamed the package to icu4j-4.2 to avoid clashes with theold package.This is not the newest version of icu4j released (that would be >= 4.4),however eclipse 3.6 depends on icu4j 4.2.The latest changelog entry:
icu4j-4.2 (4.2.1.1-1) unstable; urgency=low

* New upstream release. (Closes: #583808)
* Renamed package since eclipse 3.5.2 depends on 4.0.1.1.
* Removed dependencies on JREs - per the Java Policy this is no
longer required.
* Fixed a typo in the package synopsis.
* Rewrote d/rules to use DH7 with javahelper.
* Removed the patch; not required anymore.
* Bumped Standards-Version to 3.8.4 - no changes required.
* Removed NEWS and README.Debian; they were no longer relevant.

-- Niels Thykier <ni***@*hykier.net> Mon, 21 Jun 2010 19:40:27 +0200The changes have been checked in at the pkg-java's SVN and can also befetched from mentors.debian.net via dget:http://mentors.debian.net/debian/pool/main/i/icu4j-4.2/icu4j-4.2_4.2.1.1-1.dscThanks for considering,
~Niels


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/alpine.deb.2.00.1006212001150....@getsu.thykier.net

Offline

#2 June 22, 2010 21:36:49

Torsten W.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

RFS: icu4j-4.2


Hi Niels,

On Mon, Jun 21, 2010 at 8:10 PM, Niels Thykier <ni***@*hykier.net> wrote:
> I have prepared a new upstream release of icu4j; since eclipse 3.5 needs
> 4.0.1.1, I have renamed the package to icu4j-4.2 to avoid clashes with the
> old package.

may you add a get-orig-source target, please?

Cheers,
Torsten


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/aanlktimhj2ulj9lunks3bh16dconfcmy3g_63wo5x...@mail.gmail.com

Offline

#3 June 22, 2010 22:01:19

Scott H.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

RFS: icu4j-4.2


Hi Niels,

This is for my own education, but could you explain the following for me:

On Mon, Jun 21, 2010 at 2:10 PM, Niels Thykier <ni***@*hykier.net> wrote:
>  * Removed dependencies on JREs - per the Java Policy this is no
>    longer required.

Do we not need to depend on default-jre-headless for libraries? Or is
it optional? I don't see anything in the policy saying that it was
required to - so when is it good to include the dependency? Thank you.

Regards,
Scott


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/aanlktil_pnsxd02ubtil3wydpfngwykxs1bx75nk2...@mail.gmail.com

Offline

#4 June 22, 2010 22:24:11

Vincent F.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

RFS: icu4j-4.2


On Tue, Jun 22, 2010 at 11:00 PM, Scott Howard <showard***@*mail.com> wrote:
> On Mon, Jun 21, 2010 at 2:10 PM, Niels Thykier <ni***@*hykier.net> wrote:
>>  * Removed dependencies on JREs - per the Java Policy this is no
>>    longer required.
>
> Do we not need to depend on default-jre-headless for libraries? Or is
> it optional? I don't see anything in the policy saying that it was
> required to - so when is it good to include the dependency? Thank you.

Earlier policy (and a very outdated one, but that was reworked only
recently) mandated that libraries should depend on an appropriate java
runtime.

If my memory serves me right, only *programs* should depend on the
java runtime they need to run, but not libraries.

Cheers,

Vincent


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/aanlktikq1qs4dbgdk74m1qoxndullczeuayhnk7hd...@mail.gmail.com

Offline

#5 June 23, 2010 13:48:13

Niels T.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

RFS: icu4j-4.2


On 2010-06-22 22:36, Torsten Werner wrote:
> Hi Niels,
>
> On Mon, Jun 21, 2010 at 8:10 PM, Niels Thykier <ni***@*hykier.net> wrote:
>> I have prepared a new upstream release of icu4j; since eclipse 3.5 needs
>> 4.0.1.1, I have renamed the package to icu4j-4.2 to avoid clashes with the
>> old package.
>
> may you add a get-orig-source target, please?
>
> Cheers,
> Torsten
>
>

I made an debian/orig-tar.sh script instead, but it should work all the
same.

~Nielssignature.ascDescription:OpenPGP digital signature

Attachments:
attachment signature.asc (262 bytes)

Offline

#6 June 23, 2010 20:42:49

Torsten W.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

RFS: icu4j-4.2


On Wed, Jun 23, 2010 at 2:47 PM, Niels Thykier <ni***@*hykier.net> wrote:
> I made an debian/orig-tar.sh script instead, but it should work all the
> same.

Uploading now.

Cheers,
Torsten


--
To UNSUBSCRIBE, email to debian-java-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive:http://lists.debian.org/aanlktimkuaoj3trqht9oitzvrhlkfyxae_zqp7v5m...@mail.gmail.com

Offline

Board footer

Moderator control

Enjoy the 20th of October
PoweredBy

The Forums are managed by develissimo stuff members, if you find any issues or misplaced content please help us to fix it. Thank you! Tell us via Contact Options
Leave a Message
Welcome to Develissimo Live Support