Electronics & Programming

develissimo

Open Source electronics development and programming

  • You are not logged in.

#1 Oct. 19, 2005 22:37:01

t.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


Hi Folks,

Getting this strange error message on my admin login.

File
"/usr/lib/python2.4/site-packages/django/core/template/defaulttags.py",
line 627, in do_load
raise TemplateSyntaxError, "'%s' is not a valid tag library" %
taglib

TemplateSyntaxError: 'auth.log' is not a valid tag library


If I go to the login page for the admin console it comes up fine, as
does any non-admin page, but when I'm logged in I get this error. I did
a grep for auth.log and it seems to be loaded in the index.html
template of the admin pages.

Should mention that I've just upgraded to the latest version.

Thanks, Tom

Offline

#2 Oct. 19, 2005 22:56:40

Adrian H.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


On 10/19/05, tomass <> wrote:
> TemplateSyntaxError: 'auth.log' is not a valid tag library
>
> Should mention that I've just upgraded to the latest version.

Delete django/templatetags/*.pyc and django/templatetags/*.pyo, and
let us know if it fixes the problem.

Adrian

--
Adrian Holovaty
holovaty.com | djangoproject.com | chicagocrime.org

Offline

#3 Oct. 20, 2005 10:58:10

t.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


Works a treat, thanks!

Wonder if you've had a chance to take a look at this:http://code.djangoproject.com/ticket/480#previewStill seems to be bothering me...

Thanks, Tom

Offline

#4 Oct. 23, 2005 03:55:38

Dan L.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


I am getting an error similar to Tom's after I login to admin:

=============
File
"/usr/lib/python2.4/site-packages/django-1.0.0-py2.4.egg/django/core/template/defaulttags.py",
line 627, in do_load
raise TemplateSyntaxError, "'%s' is not a valid tag library" %
taglib

TemplateSyntaxError: 'log' is not a valid tag library
=============

I just upgraded to rev 992. I deleted the old egg first, and I also
tried removing the .pyc files as Adrian described (there were no
.pyos).

Thanks,
Dan

Offline

#5 Oct. 23, 2005 04:05:54

Jeremy D.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


On 10/22/05, Dan Lipsitt <> wrote:
>
> I am getting an error similar to Tom's after I login to admin:
>
> =============
> File
> "/usr/lib/python2.4/site-packages/django-1.0.0-py2.4.egg/django/core/template/defaulttags.py",
> line 627, in do_load
> raise TemplateSyntaxError, "'%s' is not a valid tag library" %
> taglib
>
> TemplateSyntaxError: 'log' is not a valid tag library
> =============
>
> I just upgraded to rev 992. I deleted the old egg first, and I also
> tried removing the .pyc files as Adrian described (there were no
> .pyos).

Dan, I don't know if it's related, but did you see this?http://www.djangoproject.com/weblog/2005/oct/18/admin_refactor/

Offline

#6 Oct. 23, 2005 04:22:05

Dan L.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


Thanks Jeremy, yes I did.

I'm early on in my development process, so I just deleted my db and
recreated my project directory, only copying over my models dir. So
almost everything should be fresh. Plus this happens right after I
submit my user name and password in the admin, which makes me think it
isn't about my code.

Dan

Offline

#7 Oct. 23, 2005 05:34:25

Adrian H.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


On 10/22/05, Dan Lipsitt <> wrote:
> TemplateSyntaxError: 'log' is not a valid tag library
>
> I just upgraded to rev 992. I deleted the old egg first, and I also
> tried removing the .pyc files as Adrian described (there were no
> .pyos).

Try this from the Python interactive interpreter:

>>> from django.contrib.admin.templatetags import log

If that raises an exception, it might give you some useful information.

Also, do you have "django.contrib.admin" in your INSTALLED_APPS?

Adrian

--
Adrian Holovaty
holovaty.com | djangoproject.com | chicagocrime.org

Offline

#8 Oct. 23, 2005 06:00:23

Dan L.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


> Try this from the Python interactive interpreter:
>
> >>> from django.contrib.admin.templatetags import log
>
> If that raises an exception, it might give you some useful information.

It imported fine.

> Also, do you have "django.contrib.admin" in your INSTALLED_APPS?

Yes, I do. I don't think I would see the admin login screen without it,
right?

Any other troubleshooting ideas?

Thanks,
Dan

Offline

#9 Oct. 25, 2005 03:49:40

Dan L.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


I tried on another box and had the same problems, so I filed a ticket:http://code.djangoproject.com/ticket/692

Offline

#10 Oct. 25, 2005 04:19:01

Dan L.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Tag library not found


Resolved. See the ticket mentioned above.

Offline

Board footer

Moderator control

Enjoy the 18th of November
PoweredBy

The Forums are managed by develissimo stuff members, if you find any issues or misplaced content please help us to fix it. Thank you! Tell us via Contact Options
Leave a Message
Welcome to Develissimo Live Support