Electronics & Programming

develissimo

Open Source electronics development and programming

  • You are not logged in.
  • Root
  • » KiCAD
  • » [Kicad-developers] How to apply new language ? [RSS Feed]

#1 Jan. 16, 2011 15:31:50

yone k.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[Kicad-developers] How to apply new language ?


Hello,

I have started to localize KiCad in Japanese.
I made language file (committed to lp:~kicad-developers/kicad/doc),
and modified source (attachment: kicad-jp.patch, Lang_Jp.xpm).

After 'make' and 'sudo make install',
I think KiCad was installed correctly.
But when I select language in Japanese, GUI still show in English.

My environment is
Ubuntu 10.10(x86_64), KiCad revno: 2710.

Could anybody help me? Thank's.

--
Kenta Yonekura (yoneken)kicad-jp.patchDescription:Binary data<<attachment: Lang_Jp.xpm>>_______________________________________________
Mailing list:https://launchpad.net/~kicad-developersPost to : kicad-developers@lists.launchpad.net
Unsubscribe :https://launchpad.net/~kicad-developersMore help :https://help.launchpad.net/ListHelp

Attachments:
attachment kicad-jp.patch (2.0 KB)

Offline

#2 Jan. 16, 2011 17:44:01

jean-pierre c.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[Kicad-developers] How to apply new language ?


Le 16/01/2011 16:31, yone ken a écrit :Hello,

I have started to localize KiCad in Japanese.
I made language file (committed to lp:~kicad-developers/kicad/doc),
and modified source (attachment: kicad-jp.patch, Lang_Jp.xpm).

After 'make' and 'sudo make install',
I think KiCad was installed correctly.
But when I select language in Japanese, GUI still show in English.

My environment is
Ubuntu 10.10(x86_64), KiCad revno: 2710.

Could anybody help me? Thank's.

--
Kenta Yonekura (yoneken)I committed you patch.
Tanks.
I cannot test your translation because Japanese language is not installedon my
computer.
Usually, adding your files kicad.mo and kicad.po (in fact kicad.po is just for
poedit) in subdirectory jp ou jp_JP,
inside kicad/share/internat or share/kicad/internat (depending on kicad is
installed) is enough.
(For instance, I installed kicad on my computer in /usr/local,
all kicad files are in /usr/local/kicad and translations are located in
/usr/local/kicad/share/internat)
If Japanese language if the default, select default language in kicad should
work.
(In fact the language menu selection is useful for developers to test
different language).Can you select some others languages? (Warning: these languages must alsobe installed in your Ubuntu distribution, if you want touse them in Kicad.)--
Jean-Pierre CHARRAS



_______________________________________________
Mailing list:https://launchpad.net/~kicad-developersPost to : kicad-developers@lists.launchpad.net
Unsubscribe :https://launchpad.net/~kicad-developersMore help :https://help.launchpad.net/ListHelp

Offline

#3 Jan. 17, 2011 08:04:29

yone k.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[Kicad-developers] How to apply new language ?


On Mon, Jan 17, 2011 at 2:43 AM, jean-pierre charras <jp.char***@*anadoo.fr>
wrote:
> Le 16/01/2011 16:31, yone ken a écrit :
>>
>> Hello,
>>
>> I have started to localize KiCad in Japanese.
>> I made language file (committed to lp:~kicad-developers/kicad/doc),
>> and modified source (attachment: kicad-jp.patch, Lang_Jp.xpm).
>>
>> After 'make' and 'sudo make install',
>> I think KiCad was installed correctly.
>> But when I select language in Japanese, GUI still show in English.
>>
>> My environment is
>> Ubuntu 10.10(x86_64), KiCad revno: 2710.
>>
>> Could anybody help me? Thank's.
>>
>> --
>> Kenta Yonekura (yoneken)
>>
> I committed you patch.
> Tanks.
> I cannot test your translation because Japanese language is not installedon
> my computer.
> Usually, adding your files kicad.mo and kicad.po (in fact kicad.po is just
> for poedit) in subdirectory jp ou jp_JP,
> inside kicad/share/internat or share/kicad/internat (depending on kicad is
> installed) is enough.
> (For instance, I installed kicad on my computer in /usr/local,
> all kicad files are in /usr/local/kicad and translations are located in
> /usr/local/kicad/share/internat)
> If Japanese language if the default, select default language in kicad should
> work.
> (In fact the language menu selection is useful  for developers to test
> different language).
>
> Can you select some others languages? (Warning: these languages must alsobe
> installed in your Ubuntu distribution, if you want to use them in Kicad.)
>
> --
> Jean-Pierre CHARRAS
>
>
>
> _______________________________________________
> Mailing list:https://launchpad.net/~kicad-developers> Post to     : kicad-develop***@*ists.launchpad.net
> Unsubscribe :https://launchpad.net/~kicad-developers> More help   :https://help.launchpad.net/ListHelp>

Hi JP.

I tried 3 tests.

1) Can I select any other languages?
2) Can I edit any other languages?
3) If I exchange jp/kicad.mo with other/kicad.mo, GUI shows in other language?

The results are:
1) OK - After I installed French on my computer, GUI menus show in French.
2) OK - After I edited fr/kicad.mo, the text is changed.
3) NG - After I exchange fr/kicad.mo with jp/kicad.mo, GUI shows in English.

According to these results, I think this issue is not from the language file
but from the KiCad source.

Any suggestions would be appreciated.



Thanks.

--
Kenta Yonekura (yoneken)

_______________________________________________
Mailing list:https://launchpad.net/~kicad-developersPost to : kicad-developers@lists.launchpad.net
Unsubscribe :https://launchpad.net/~kicad-developersMore help :https://help.launchpad.net/ListHelp

Offline

#4 Jan. 17, 2011 20:27:52

jean-pierre c.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[Kicad-developers] How to apply new language ?


Le 17/01/2011 09:04, yone ken a écrit :On Mon, Jan 17, 2011 at 2:43 AM, jean-pierre charras<jp.char***@*anadoo.fr>
wrote:Le 16/01/2011 16:31, yone ken a écrit :Hello,

I have started to localize KiCad in Japanese.
I made language file (committed to lp:~kicad-developers/kicad/doc),
and modified source (attachment: kicad-jp.patch, Lang_Jp.xpm).Hi JP.

I tried 3 tests.

1) Can I select any other languages?
2) Can I edit any other languages?
3) If I exchange jp/kicad.mo with other/kicad.mo, GUI shows in other language?

The results are:
1) OK - After I installed French on my computer, GUI menus show in French.
2) OK - After I edited fr/kicad.mo, the text is changed.
3) NG - After I exchange fr/kicad.mo with jp/kicad.mo, GUI shows in English.

According to these results, I think this issue is not from the language file
but from the KiCad source.

Any suggestions would be appreciated.I made some tests with wxWidgets.
wxWidgets seems look for ja/kicad.mo, not jp/kicad.mo to find Japanese
dictionnary.

(see wxWidgets/samples/internat for more tests)




--
Jean-Pierre CHARRAS


_______________________________________________
Mailing list:https://launchpad.net/~kicad-developersPost to : kicad-developers@lists.launchpad.net
Unsubscribe :https://launchpad.net/~kicad-developersMore help :https://help.launchpad.net/ListHelp

Offline

#5 Jan. 18, 2011 05:04:56

yone k.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[Kicad-developers] How to apply new language ?


On Tue, Jan 18, 2011 at 5:27 AM, jean-pierre charras <jp.char***@*anadoo.fr>
wrote:
> Le 17/01/2011 09:04, yone ken a écrit :
>>
>> On Mon, Jan 17, 2011 at 2:43 AM, jean-pierre
>> charras<jp.char***@*anadoo.fr>  wrote:
>>>
>>> Le 16/01/2011 16:31, yone ken a écrit :
>>>>
>>>> Hello,
>>>>
>>>> I have started to localize KiCad in Japanese.
>>>> I made language file (committed to lp:~kicad-developers/kicad/doc),
>>>> and modified source (attachment: kicad-jp.patch, Lang_Jp.xpm).
>>>>
>>>>
>>
>> Hi JP.
>>
>> I tried 3 tests.
>>
>> 1) Can I select any other languages?
>> 2) Can I edit any other languages?
>> 3) If I exchange jp/kicad.mo with other/kicad.mo, GUI shows in other
>> language?
>>
>> The results are:
>> 1) OK - After I installed French on my computer, GUI menus show in French.
>> 2) OK - After I edited fr/kicad.mo, the text is changed.
>> 3) NG - After I exchange fr/kicad.mo with jp/kicad.mo, GUI shows in
>> English.
>>
>> According to these results, I think this issue is not from the language
>> file
>> but from the KiCad source.
>>
>> Any suggestions would be appreciated.
>>
>
> I made some tests with wxWidgets.
> wxWidgets seems look for ja/kicad.mo, not jp/kicad.mo to find Japanese
> dictionnary.
>
> (see wxWidgets/samples/internat for more tests)
>

Thanks JP,

I followed to your advice and finally I succeeded to apply Japanese to KiCad !

Some time ago, I pushed my commit to lp:~kicad-developers/kicad/doc.
Perhaps I damaged to French translation (JP's previous commit)..
I'm very sorry...  I should study for Bazaar.

--
Kenta Yonekura (yoneken)





_______________________________________________
Mailing list:https://launchpad.net/~kicad-developersPost to : kicad-developers@lists.launchpad.net
Unsubscribe :https://launchpad.net/~kicad-developersMore help :https://help.launchpad.net/ListHelp

Offline

#6 Jan. 18, 2011 14:20:13

Dick H.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[Kicad-developers] How to apply new language ?


> Thanks JP,
>
> I followed to your advice and finally I succeeded to apply Japanese to KiCad !
>
> Some time ago, I pushed my commit to lp:~kicad-developers/kicad/doc.
> Perhaps I damaged to French translation (JP's previous commit)..
> I'm very sorry... I should study for Bazaar.

Use BZR's 'commit', *not* 'push' when updating a public *shared* repository. :)





_______________________________________________
Mailing list:https://launchpad.net/~kicad-developersPost to : kicad-developers@lists.launchpad.net
Unsubscribe :https://launchpad.net/~kicad-developersMore help :https://help.launchpad.net/ListHelp

Offline

  • Root
  • » KiCAD
  • » [Kicad-developers] How to apply new language ? [RSS Feed]

Board footer

Moderator control

Enjoy the 20th of October
PoweredBy

The Forums are managed by develissimo stuff members, if you find any issues or misplaced content please help us to fix it. Thank you! Tell us via Contact Options
Leave a Message
Welcome to Develissimo Live Support