Electronics & Programming

develissimo

Open Source electronics development and programming

  • You are not logged in.

#1 March 12, 2008 11:13:40

Alex I.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

Expose glitch?


Hi!

I've created a transparent window with GTK under GNOME.

The problem I have is that when I first show the window I see for a short
period of time an white opaque background inside my frame.

I've made my "top window" transparent painting it with Cairo inside the expose
event.

I don't think this problem is Cairo related though because every GNOME window I
see seems to have a small delay when first loaded. The expose event seems not
to be triggered right away...

If I choose a "popup" window style for my window instead of "top level" this
problem doesn't appear, its painted right away. But the "popup" style
introduces a lot of undesired effects in my applications.

Can anybody help me please? This problem is really annoying especially for a
transparent window!

Best Regards,
Alex


---------------------------------
Looking for last minute shopping deals? Find them fast with Yahoo! Search._______________________________________________
gtk-list mailing list
gtk-list@gnome.orghttp://mail.gnome.org/mailman/listinfo/gtk-list

Offline

Board footer

Moderator control

Enjoy the 16th of December
PoweredBy

The Forums are managed by develissimo stuff members, if you find any issues or misplaced content please help us to fix it. Thank you! Tell us via Contact Options
Leave a Message
Welcome to Develissimo Live Support