Electronics & Programming

develissimo

Open Source electronics development and programming

  • You are not logged in.
  • Root
  • » PHP
  • » [PHP-DEV] 5.1.0RC5-dev stability issue [RSS Feed]

#1 Nov. 7, 2005 00:46:47

Jared W.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[PHP-DEV] 5.1.0RC5-dev stability issue


Hi,
I'm having stability issues with isapi php5.1 RC4 (php -I reports rc5,
but it was rc4 dled fromhttp://downloads.php.net/ilia/), its either throwing an "PHP has encountered an
Access Violation at 77FCC024" or "The remote
procedure call failed."

Just asking how to gather more information, as I presume just the above
is not helpful in tracking the problem causing this.

Jared

PHP Version => 5.1.0RC5-dev
System => Windows NT WIN2KS 5.0 build 2195 Build Date => Nov 5 2005 12:32:41
Configure Command => cscript /nologo configure.js
"--enable-snapshot-build" "--with-gd=shared"

With just pdo, pdo_sqlite, and xsl extenstions.

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit:http://www.php.net/unsub.php

Offline

#2 Nov. 7, 2005 02:37:53

Wez F.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[PHP-DEV] 5.1.0RC5-dev stability issue


If it's isapi then the chances are that its some non-trivial
thread-safety related problem.
Unless you built a debug build of PHP yourself and have a debugger, it
will be very hard to isolate. Even with a debugger, you'll probably
only spot a crash that's a symptom of the problem and not the cause.

While we are interested in solving the problem, it usually takes a
significant number of man hours to get a handle on what's going wrong,
and even when that problem is solved, there's usually some other
problem(s) that also require a similar time investment to resolve.
Debugging thread problems is usually "too hard" (not interesting or
satisfying enough) to be done in spare time, so they tend not to get
solved.

These are some of the reasons that we recommend that you avoid using
PHP in threaded environments; it's much more cost effective to go with
fastcgi; Zend's WinEnabler is modestly priced, and Shane Caraveo's
implementation is free.

--Wez.

On 11/6/05, Jared Williams <> wrote:
>
> Hi,
> I'm having stability issues with isapi php5.1 RC4 (php -I reports
> rc5, but it was rc4 dled from
>http://downloads.php.net/ilia/), its either throwing an "PHP has encountered
> an Access Violation at 77FCC024" or "The remote
> procedure call failed."
>
> Just asking how to gather more information, as I presume just the
> above is not helpful in tracking the problem causing this.
>
> Jared
>
> PHP Version => 5.1.0RC5-dev
> System => Windows NT WIN2KS 5.0 build 2195 Build Date => Nov 5 2005 12:32:41
> Configure Command => cscript /nologo configure.js
> "--enable-snapshot-build" "--with-gd=shared"
>
> With just pdo, pdo_sqlite, and xsl extenstions.
>
> --
> PHP Internals - PHP Runtime Development Mailing List
> To unsubscribe, visit:http://www.php.net/unsub.php>
>

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit:http://www.php.net/unsub.php

Offline

#3 Nov. 7, 2005 11:47:51

Jared W.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[PHP-DEV] 5.1.0RC5-dev stability issue


Ok, its just that 5.1.0 RC1 was quite stable. Can no longer find it to download
to check though.

Jared

> -----Original Message-----
> From: Wez Furlong
> Sent: 07 November 2005 02:37
> To:
> Cc: intern***@*ists.php.net
> Subject: Re: 5.1.0RC5-dev stability issue
>
> If it's isapi then the chances are that its some non-trivial
> thread-safety related problem.
> Unless you built a debug build of PHP yourself and have a
> debugger, it will be very hard to isolate. Even with a
> debugger, you'll probably only spot a crash that's a symptom
> of the problem and not the cause.
>
> While we are interested in solving the problem, it usually
> takes a significant number of man hours to get a handle on
> what's going wrong, and even when that problem is solved,
> there's usually some other
> problem(s) that also require a similar time investment to resolve.
> Debugging thread problems is usually "too hard" (not
> interesting or satisfying enough) to be done in spare time,
> so they tend not to get solved.
>
> These are some of the reasons that we recommend that you
> avoid using PHP in threaded environments; it's much more cost
> effective to go with fastcgi; Zend's WinEnabler is modestly
> priced, and Shane Caraveo's implementation is free.
>
> --Wez.
>
> On 11/6/05, Jared Williams <> wrote:
> >
> > Hi,
> > I'm having stability issues with isapi php5.1 RC4 (php -I
> > reports rc5, but it was rc4 dled from
>http://downloads.php.net/ilia/),
> > its either throwing an "PHP has encountered an Access
> Violation at 77FCC024" or "The remote procedure call failed."
> >
> > Just asking how to gather more information, as I
> presume just the above is not helpful in tracking the problem
> causing this.
> >
> > Jared
> >
> > PHP Version => 5.1.0RC5-dev
> > System => Windows NT WIN2KS 5.0 build 2195 Build Date =>
> Nov 5 2005
> > 12:32:41 Configure Command => cscript /nologo configure.js
> "--enable-snapshot-build" "--with-gd=shared"
> >
> > With just pdo, pdo_sqlite, and xsl extenstions.
> >
> > --
> > PHP Internals - PHP Runtime Development Mailing List To
> unsubscribe,
> > visit:http://www.php.net/unsub.php> >
> >
>
> --
> PHP Internals - PHP Runtime Development Mailing List To
> unsubscribe, visit:http://www.php.net/unsub.php>

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit:http://www.php.net/unsub.php

Offline

#4 Nov. 7, 2005 16:56:16

Jani T.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[PHP-DEV] 5.1.0RC5-dev stability issue


Are you absolutely sure you don't have some old dlls laying around
from some earlier PHP version that don't mix with the new one?

--Jani


On Mon, 7 Nov 2005, Jared Williams wrote:Ok, its just that 5.1.0 RC1 was quite stable. Can no longer find it to download
to check though.

Jared-----Original Message-----
From: Wez Furlong
Sent: 07 November 2005 02:37
To:
Cc: intern***@*ists.php.net
Subject: Re: 5.1.0RC5-dev stability issue

If it's isapi then the chances are that its some non-trivial
thread-safety related problem.
Unless you built a debug build of PHP yourself and have a
debugger, it will be very hard to isolate. Even with a
debugger, you'll probably only spot a crash that's a symptom
of the problem and not the cause.

While we are interested in solving the problem, it usually
takes a significant number of man hours to get a handle on
what's going wrong, and even when that problem is solved,
there's usually some other
problem(s) that also require a similar time investment to resolve.
Debugging thread problems is usually "too hard" (not
interesting or satisfying enough) to be done in spare time,
so they tend not to get solved.

These are some of the reasons that we recommend that you
avoid using PHP in threaded environments; it's much more cost
effective to go with fastcgi; Zend's WinEnabler is modestly
priced, and Shane Caraveo's implementation is free.

--Wez.

On 11/6/05, Jared Williams <> wrote:Hi,
I'm having stability issues with isapi php5.1 RC4 (php -I
reports rc5, but it was rc4 dled fromhttp://downloads.php.net/ilia/),its either throwing an "PHP has encountered an AccessViolation at 77FCC024" or "The remote procedure call failed."Just asking how to gather more information, as Ipresume just the above is not helpful in tracking the problem
causing this.Jared

PHP Version => 5.1.0RC5-dev
System => Windows NT WIN2KS 5.0 build 2195 Build Date =>Nov 5 200512:32:41 Configure Command => cscript /nologo configure.js"--enable-snapshot-build" "--with-gd=shared"With just pdo, pdo_sqlite, and xsl extenstions.

--
PHP Internals - PHP Runtime Development Mailing List Tounsubscribe,visit:http://www.php.net/unsub.php--
PHP Internals - PHP Runtime Development Mailing List To
unsubscribe, visit:http://www.php.net/unsub.php--
Give me your money at @ <http://pecl.php.net/wishlist.php/sniper>
Donating money may make me happier and friendlier for a limited period!
Death to all 4 letter abbreviations starting with P!

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit:http://www.php.net/unsub.php

Offline

#5 Nov. 7, 2005 17:16:05

Jared W.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

[PHP-DEV] 5.1.0RC5-dev stability issue


> Are you absolutely sure you don't have some old dlls
> laying around
> from some earlier PHP version that don't mix with the new one?
>
> --Jani

I don't think that could be the case, as just pdo, pdo_sqlite, and xsl
extensions are enabled, none have any external dependancies
afaik.
And they're all packaged within the same zip.

Jared

> On Mon, 7 Nov 2005, Jared Williams wrote:
>
> >
> >
> > Ok, its just that 5.1.0 RC1 was quite stable. Can no longer
> find it to download to check though.
> >
> > Jared
> >
> >>
> >> If it's isapi then the chances are that its some non-trivial
> >> thread-safety related problem.
> >> Unless you built a debug build of PHP yourself and have a
> debugger,
> >> it will be very hard to isolate. Even with a debugger, you'll
> >> probably only spot a crash that's a symptom of the problem and not
> >> the cause.
> >>
> >> While we are interested in solving the problem, it usually takes a
> >> significant number of man hours to get a handle on what's going
> >> wrong, and even when that problem is solved, there's usually some
> >> other
> >> problem(s) that also require a similar time investment to resolve.
> >> Debugging thread problems is usually "too hard" (not
> interesting or
> >> satisfying enough) to be done in spare time, so they tend
> not to get
> >> solved.
> >>
> >> These are some of the reasons that we recommend that you
> avoid using
> >> PHP in threaded environments; it's much more cost effective to go
> >> with fastcgi; Zend's WinEnabler is modestly priced, and Shane
> >> Caraveo's implementation is free.
> >>
> >> --Wez.
> >>
> >> On 11/6/05, Jared Williams <> wrote:
> >>>
> >>> Hi,
> >>> I'm having stability issues with isapi php5.1 RC4 (php -I
> >>> reports rc5, but it was rc4 dled from
> >>http://downloads.php.net/ilia/),
> >>> its either throwing an "PHP has encountered an Access
> >> Violation at 77FCC024" or "The remote procedure call failed."
> >>>
> >>> Just asking how to gather more information, as I
> >> presume just the above is not helpful in tracking the
> problem causing
> >> this.
> >>>
> >>> Jared
> >>>
> >>> PHP Version => 5.1.0RC5-dev
> >>> System => Windows NT WIN2KS 5.0 build 2195 Build Date =>
> >> Nov 5 2005
> >>> 12:32:41 Configure Command => cscript /nologo configure.js
> >> "--enable-snapshot-build" "--with-gd=shared"
> >>>
> >>> With just pdo, pdo_sqlite, and xsl extenstions.
> >>>
> >>> --
> >>> PHP Internals - PHP Runtime Development Mailing List To
> >> unsubscribe,
> >>> visit:http://www.php.net/unsub.php> >>>
> >>>
> >>
> >> --
> >> PHP Internals - PHP Runtime Development Mailing List To
> unsubscribe,
> >> visit:http://www.php.net/unsub.php> >>

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit:http://www.php.net/unsub.php

Offline

  • Root
  • » PHP
  • » [PHP-DEV] 5.1.0RC5-dev stability issue [RSS Feed]

Board footer

Moderator control

Enjoy the 18th of November
PoweredBy

The Forums are managed by develissimo stuff members, if you find any issues or misplaced content please help us to fix it. Thank you! Tell us via Contact Options
Leave a Message
Welcome to Develissimo Live Support